Shockwave Flash is known to be vulnerable and should be updated error?

If you get those annoying messages on top of your screen from where you need to click “allow” all the time, good news, there is a simple fix.

Shockwave-Flash-firefox

First, download and run this tool which is an Adobe Flash uninstaller (official software from Adobe).

Then install this full Flash player. Here is the download link.

Install the software and run Firefox. Go to addons, you should not encounter the error anymore.

You can’t actually update Shockwave Flash directly from Firefox, you will get this error: “Flash Player Plugin between 11.0 and 11.7.700.169 (click-to-play) has been blocked for your protection.”.

ADD A COMMENT: